RUBE Editor can't load data files in High Sierra

General discussion about the R.U.B.E editor
Post Reply
ptc79
Posts: 11
Joined: Tue Apr 02, 2013 9:45 pm

RUBE Editor can't load data files in High Sierra

Post by ptc79 » Mon Jun 11, 2018 7:30 pm

Hi, I've recently bought a new mac running High Sierra. For some reason RUBE Editor can't seem to load any data files on this system.

When I run the application I get this message in the message log "Could not find help file rubehelp_en.qhc". Obviously no help information is visible in the help panel either because the file hasn't loaded. Also when I press the spacebar in the editor view I get the message "no actions registered". So the file that loads the actions data hasn't loaded either.

The OS version I'm using is High Sierra 10.13.5, and the RUBE version is 1.7.4. I have tried installing RUBE Editor a few different times on the machine but to no avail. When I unzipped the files I didn't move any of them to new locations. I kept them all in the rube-mac32-1.7.4 folder. I have even tried unzipping the files in the Applications directory itself, but this didn't work.

Any ideas why the files might not be loading? Could it be the OS blocking files from being loaded, or am I doing something wrong? Thanks in advance for your help.

ptc79
Posts: 11
Joined: Tue Apr 02, 2013 9:45 pm

Re: RUBE Editor can't load data files in High Sierra

Post by ptc79 » Mon Jun 11, 2018 7:40 pm

I solved this problem by opening the app from terminal, like you showed in the other thread.

https://www.iforce2d.net/forums/viewtopic.php?f=7&t=540

Thanks for the info.

qq200600
Posts: 29
Joined: Fri Dec 28, 2012 9:27 am

Re: RUBE Editor can't load data files in High Sierra

Post by qq200600 » Sat Sep 08, 2018 12:52 am

me too, ----------> No action registered

Post Reply