R.U.B.E bug OS X 10.9 Mavericks

Report problems here (or use the built-in feedback dialog in the editor)
iforce2d
Site Admin
Posts: 857
Joined: Sat Dec 22, 2012 7:20 pm

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by iforce2d » Tue Nov 12, 2013 6:27 am

I think this build should fix the issue, but I cannot confirm that myself: rube-mac32-1.5.2-rc1.zip
Could some 10.9 users give it a try before I make a proper update? Thanks!

alexf
Posts: 1
Joined: Sun Nov 10, 2013 11:29 pm

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by alexf » Tue Nov 12, 2013 3:33 pm

Works! Just drop in the same location as R.U.B.E.app and you're good to go.

coder_stu
Posts: 1
Joined: Tue Nov 12, 2013 9:05 pm

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by coder_stu » Tue Nov 12, 2013 9:09 pm

Yep, works perfectly for me too! Thanks for the fix @iforce2d, I look forward to seeing it come through in the next build :D

iforce2d
Site Admin
Posts: 857
Joined: Sat Dec 22, 2012 7:20 pm

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by iforce2d » Wed Nov 13, 2013 11:30 am

Okay, this should be fixed by v1.5.2 which has just been uploaded. Thanks for being patient :)

therealcos
Posts: 16
Joined: Tue Aug 20, 2013 7:30 am

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by therealcos » Mon Feb 17, 2014 11:21 pm

I tried everything in this thread and I'm still seeing this issue. I just downloaded v1.5.4 and it's still giving me the same problem - any ideas?

therealcos
Posts: 16
Joined: Tue Aug 20, 2013 7:30 am

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by therealcos » Mon Feb 17, 2014 11:23 pm

Gah, nevermind me - it works!

ascorbic
Posts: 1
Joined: Mon Oct 08, 2018 1:13 pm

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by ascorbic » Mon Oct 08, 2018 1:16 pm

I'm getting this problem in Mac OS 10.13, with R.U.B.E. 1.7.4. Symptoms exactly the same: if launched the normal way, the help file is not found and no actions are registered. Works fine if launched form the command line within the application directory. Is this a regression? It's quite inconvenient.

iforce2d
Site Admin
Posts: 857
Joined: Sat Dec 22, 2012 7:20 pm

Re: R.U.B.E bug OS X 10.9 Mavericks

Post by iforce2d » Mon Oct 08, 2018 11:20 pm

With each new OS release Apple seems to find new ways to break existing programs that were working perfectly well before. I suppose you could call that regression. While Windows and Linux continue to run decades old software without any problems, Apple has a total disregard for basic backward compatibility.

If by 'inconvenient' you mean that you need to open a terminal and type something, I'm pretty sure you could set up a way to just have it clickable from the dock (again, on Windows or Linux this would be pretty trivial but with OSX I have learned to never assume anything will be easy). Perhaps some ideas here might help: https://stackoverflow.com/questions/281 ... -os-x-dock

It's quite likely that if you make a shell script to run a GUI program, the terminal window will hang around the whole time it's running (and closing the terminal window will kill the program) which can be annoying. On Linux you can use 'disown' to avoid this by relinquishing parentage of a background process, for example:

./myprogram.sh &
disown

... now you can close the terminal window and the GUI application will keep running. I have not checked if this works on OSX but 'disown' does seem to exist at least, so it's worth a try.

Post Reply