R.U.B.E editor stopped working on Win 10

Report problems here (or use the built-in feedback dialog in the editor)
Post Reply
Posts: 1
Joined: Sat Sep 29, 2018 2:10 pm

R.U.B.E editor stopped working on Win 10

Post by jaggie »

I have so far been successfully using RUBE editor 1.7.4 on my Windows 10 (Pro, v1803) laptop without any major issues. But today when I started it, only the message log window appeared, rest of the editor was missing. I closed the editor (by right clicking the icon on the task bar and selecting close) and started it again. Same thing. I closed the message log, closed RUBE, started again, and now nothing appears on the screen, as if the RUBE window was completely invisible. The icon appears on the task bar when I open the editor, and when I move my mouse cursor over it, the preview icon (small picture of the RUBE window) looks correct with all the editor content (except for the message log). Also on the task view it is visible. But when I click that icon, the editor window will not appear.

I have tried
- shift and right click the RUBE icon on task bar, selecting move / size / minimize / maximize -> no effect
- right clicking the task bar, selecting cascade windows / show windows stacked -> empty spot(s) are left for each instance of RUBE editor that I have "open", but the editor will not appear there
- restarting the computer and all of the above again - no effect
- copying the files from the original rube-win32-1.7.4.zip package to a new directory and staring the editor from there - same behavior.
- trying to launch the editor by double-clicking a .rube file - no effect (however that has never worked on this PC even though RUBE is assigned as the application that opens these files)

I have not done any update nor any other changes to the computer since last time the RUBE editor worked, and I don't have similar problem with any other application.

Any help/ideas would be greatly appreciated!
Site Admin
Posts: 861
Joined: Sat Dec 22, 2012 7:20 pm

Re: R.U.B.E editor stopped working on Win 10

Post by iforce2d »

The only thing I can suppose as a possibility is that the .ini file which stores the positions of the panels, has become corrupted somehow. This .ini file ( on Windows the file is called rube.ini and can be found in %APPDATA%\iforce2d ) is checked on startup to place all the docking panels where you had them last time. If the file is messed up maybe the windows are being positioned somewhere way off your desktop. You could either delete that file completely, or if it is still editable as text, you could just remove everything in the [mainwindow] section.... I think. Don't edit the file while RUBE is running because it will overwrite your changes when it closes.
Post Reply