Which version of Box2D should I use?

General discussion about the R.U.B.E editor
Post Reply
KAMIKAZE
Posts: 3
Joined: Thu Nov 02, 2017 12:52 pm

Which version of Box2D should I use?

Post by KAMIKAZE » Thu Nov 02, 2017 12:58 pm

v2.3.2 (latest in a code, so just use/download latest code from git) https://github.com/erincatto/Box2D/blob ... gs.cpp#L24

v.2.3.1 (latest on releases, but 3y old )
https://github.com/erincatto/Box2D/releases/tag/v2.3.1

@iforce2d Which version you are using in all your games?

iforce2d
Site Admin
Posts: 860
Joined: Sat Dec 22, 2012 7:20 pm

Re: Which version of Box2D should I use?

Post by iforce2d » Fri Nov 03, 2017 12:16 am

I think I used 2.3.0 or 2.3.1 for most of my stuff. As far as I know there is very little difference to the library itself for a long time, most of the changes were to the testbed GUI from about 2.3 onward.

KAMIKAZE
Posts: 3
Joined: Thu Nov 02, 2017 12:52 pm

Re: Which version of Box2D should I use?

Post by KAMIKAZE » Fri Nov 03, 2017 10:01 am

There are actually some code changes like fixes.

KAMIKAZE
Posts: 3
Joined: Thu Nov 02, 2017 12:52 pm

Re: Which version of Box2D should I use?

Post by KAMIKAZE » Sat Nov 04, 2017 7:32 pm

iforce2d wrote:I think I used 2.3.0 or 2.3.1 for most of my stuff. As far as I know there is very little difference to the library itself for a long time, most of the changes were to the testbed GUI from about 2.3 onward.
So, which version you are using nowadays?

iforce2d
Site Admin
Posts: 860
Joined: Sat Dec 22, 2012 7:20 pm

Re: Which version of Box2D should I use?

Post by iforce2d » Mon Nov 06, 2017 3:43 am

As I said above, I use 2.3.0 or 2.3.1 for most of my stuff and there is very little difference to the library features since then. Bugfixes are not features and will not affect the way you write your own program.

Post Reply